Unable to Log in to Website
Incident Report for PAI Industries
Resolved
This incident has been resolved.
Posted Jan 29, 2024 - 09:36 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2024 - 09:25 EST
Identified
We have identified an issue preventing users from logging into the website. We are working towards deploying a solution.
Posted Jan 29, 2024 - 09:19 EST
This incident affected: Customer Portal.