Credit Cart transactions in our Canadian Branch.
Incident Report for PAI Industries
Resolved
The issue with Canada credit cards has been resolved.
Posted Jul 18, 2024 - 13:59 EDT
Investigating
We are aware of issues with processing credit card transactions for our Canadian customers. We are working with our processor to identify the underlying issue.
Posted Jul 18, 2024 - 11:08 EDT
This incident affected: Customer Portal and ERP System.