Email Blocked
Incident Report for PAI Industries
Resolved
The issue with sending emails has been resolved.
Posted Jul 24, 2024 - 12:34 EDT
Investigating
We are experiencing an issue with sending emails to recipients outside of our organization.
Posted Jul 24, 2024 - 11:32 EDT
This incident affected: Customer Portal, ERP System, Intranet Website, and Email System.