Toll Free number for Domestic Sales Department

Incident Report for PAI Industries

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 10:40 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 18, 2025 - 20:29 EDT

Investigating

We are currently investigating an issue with the toll free number 1-800-654-3721 for our Domestic Sales Department. While we work to resolve this issue, please use the phone number for our PAI Corporate HQ 1-770-822-1000 (menu option #2) or 1-678-518-6575 to reach our sales team by phone.
Posted Mar 18, 2025 - 13:58 EDT
This incident affected: Phone System.