DUO experiencing temporary authentication issues with SMS text/phone call delivery

Incident Report for PAI Industries

Resolved

This incident has been resolved.
Posted Feb 13, 2025 - 20:22 EST

Monitoring

DUO has identified the root cause for temporary issues with authenticating via SMS text/phone call delivery and are working on deploying a fix - please use the DUO Push notification if possible until they have the issue fully resolved. Below is the link to DUO's status page where we are monitoring the situation.

https://status.duo.com/
Posted Feb 13, 2025 - 15:22 EST
This incident affected: Duo SSO, Duo Core Authentication Service, Duo SMS Message Delivery, and Duo Phone Call Delivery.