Wireless Network Connectivity
Incident Report for PAI Industries
Resolved
This incident has been resolved.
Posted Jan 19, 2024 - 08:57 EST
Identified
We are aware of an issue with the PAI Wireless network and are working to resolve the issue. Next update will be at 5:30 AM EST.
Posted Jan 19, 2024 - 08:18 EST
This incident affected: General Network Connectivity.